2018年4月10日

Linkstation LS-QVLの本体が壊れたよ!・・・データー 救出劇


Buffalo、Linkstation LS-QVL、2台を使用していますが、突然、1台が起動しなくなりました
その壊れたLinkstation LS-QVLの本体からHDDを取り外し、そのデーターの救出の顛末を忘れないため備忘録として記します!
     
上段が壊れました、下段は正常動作中


どういう状態か? 青ランプ点滅です・・・NasNavigtorをみれば、EMモード・・・対処は?
・・・最新ファームウエアを更新して、ダメなら修理と・・・あります

この状態が起きる前に、最新ファームウエア 1.74に更新しています
その更新から、僅かな日数で、青ランプ点滅で、起動しなくなりました
最新ファームウエア 1.74に更新の失敗? いや、更新後も正常動作していましたので?

LS-QVL・・・以前はRAID1で運用していましたが、使用上、RAID1での安全策は不要となり、4台のHDDを個別に運用する通常モードに切り替えました

Disk1には、shareフォルダがあり、DTCP-IP、DNLA機能で、地デジ録画などのムーブ、保存先と・・Disk2~4は、所謂、動画、写真データなどを保存して稼働させていました

で、こういう場合は、定番、Linuxの「ubuntuまたはKnoppix」で、救出と安易に考えていました
使用の出番の無い、Toshiba dynabook TX/66Aを使い、ubuntuをインストールです

・・・ここからが、素人の知識の無さが露呈します・・・

ubuntuの、インストールは終わり、USBとしてLS-QVLのDisk4を取付、マウントへ・・・
ところが、ところがです・・・認識しません おいおい、どうしたのか?

さぁ、ドツボへの入り口に立ってしまいました

先人の教えのとうり、試すも、マウントもできない・・・
Gpartedで、調べると、HDDのフォーマット形式は「XFS」そして、RAIDの文字が・・・

ubuntu、Knoppix、Puffy、ZoneOS・・・全てをダウンロードしてDVDを作成し、試しました・・
しかし結果は、悉くXFSを認識しませんでした
これは、恐らく、RAID構築の際のなにかが影響して、マウントできないのでは?・・・想像ですが!

思いつきですが、そうなれば、サーバ用のLinuxディストリビューションを試そうかと!

で、Linuxディストリビューション・・Linux CentOS7をインストールです
インストール後、USBとしてLS-QVLのDisk4を取付・・・おおぉ、認識しましたね!・・・
理屈はわかりませんが、正解?でした

しかし、HDDの表示ではなく、NAS(RAIDアレイ)で表示されています
しかも、4つあります・・・Gpartedで、調べた折りに出ていたパーティションですね
所謂、sda1~sda6とかいうやつでしょうね・・・

そして、上赤四角・・・「アレイはデグレードしています」・・なんじゃ、これは?

・・・デグレードモード(劣化した(機能上の)形態)は、RAIDに搭載されている複数のハーディスクのうちの一台またはグループが故障しているか認識できない障害が起きている状態・・をいうらしい!

で、先人の教えでは・・赤丸の▲?を押すらしい・・・お!・・内容を表示してくれました・・・
と、なればHDDの内容は壊れていない・・・中身が見えればそれでいいのです・・・よし!

ここまで、苦節?3日間・・・
なににせよ、バックアップ用の500GBのHDDを、EXT3でフォーマットして、ファイルのコピーです(なぜか、NFTSでフォーマットしたHDDが認識しなかったのです・・原因追及は今はしません、データ救出をしなければ)


これで、RAIDで作成されたxfsフォーマットのHDDからのデータ救出は、無事できることになりました

よくよく、考えれば、RAID構成では、全部DATAは飛んでしまっていたのでしょうね
と、なればNASも使用用途で構成もよく考えなければ・・ね!

Windows7にて、バックアップしたHDDの内容を見るには・・・Ext2 Volume Managerを使います
Windows7にExt2 Volume Managerをインストールし、Linux、EXT3のHDDをエクスプローラーで使えるようにします

下、赤枠・・EXT3 456GB/61GBと表示されました
そして、その部分をクリックすると・・・

赤丸のように「レ」 ドライブレタを決め、Applyを押すと・・・

Windows7のエクスプローラー表示で、表示されました

内容を確認すると・・・うんうん! 完璧や!
(上のデータコピー時のHDDと表示は異なります)

取り外す折りには、「レ」を外し、Applyを押せば、解除となる

ここまでたどり着くこと、4日間がかかりました・・・よかったです

残念なことに、CentOS7は、ネットワーク、所謂、イーサーネットを認識しません
先人が・・・CentOS7は、旧機種、i386のドライバが認識されないと・・・アチャ!!
後日、この辺はトライしてみます・・・

最後に・・残念ながら、Disk1のShare内の地デジ、ムーブ保存したものは、諦めなければなりません
なにか、方法がないか、ググってみます・・・無理やろなぁ・・・(>_<)

最後に、上記の顛末は、素人の発想からの方法・・・恐らく、間違っているでしょう・・
まぁ、その辺は、無知な素人として、ご容赦を・・・

そういうデータ救出の顛末でした



0 件のコメント:

コメントを投稿